Tato stránka používá Cookies. Informace o Cookies.
 
PRO MOBIL
PRO MOBIL
KLASICKY
KLASICKY


Software

Dvanáct nejoblíbenějších vzorců v Excelu (i s příklady)! - 11.díl

Určitě znáte v Excelu nejoblíbenější funkce data a času? Ovládáte v Excelu různé matematické triky a pracujete v tabulkovém procesoru s nástroji pro manipulaci s daty?

Předcházející díl

 

Tabulkový procesor MS Excel má ve své databázi funkcí přes 475 nejrůznějších vzorců – od těch nejjednodušších pro jednoduché matematické operace až po velmi komplikované funkce pro statistické, logické a technické výpočty. Typickým příkladem jsou příkazy IF (jeden z námi vůbec nejoblíbenějších vzorců), dále funkce A, NEBO, NE či funkce POČET, PRŮMĚR a MIN/MAX.

Na následujících řádcích se budeme věnovat dvanácti neoblíbenějším vzorcům používaným právě v programu MS Excel. A abychom vám pomohli s jejich používáním, budete mít k dispozici sešit Excelu s příklady použití každého z těchto vzorců. Tento sešit si můžete stáhnout na adrese https://images.idgesg.net/assets/2018/10/basic20formulas.xlsx.

11. Příkaz KDYŽ

Funkce KDYŽ (také se často označuje jako příkaz KDYŽ), funguje na základě principu souslednosti následujících spojek: když, pak, jinak (IF, then, else). V podstatě to znamená, že pokud je nějaká podmínka splněna, pak udělejte jednu operaci, v opačném případě udělejte něco jiného. Tak například pokud štěně bude Labrador, pak mu kupte modrý obojek, jinak kupte oboje červený.

Syntaxe této funkce či příkazu (neboli způsob, jakým budou jednotlivé příkazy ve vzorci seřazeny) KDYŽ je následující: =KDYŽ(test podmínky, hodnota v případě, kdy je podmínka splněna, hodnota v případě, kdy podmínka není splněna). Příkazy KDYŽ se používají ve všech programovacích jazycích a i přesto, že se pokaždé syntaxe nepatrně liší, dává tato funkce stejný výstup.

1. Vytvořte v buňkách následující hlavičky sloupců: Cookie Boxes Sold; 3rd Prize =More than 500 Sold, Less than 1000; 2nd Prize =More than 1000 Sold, Less than 1500; 1st Prize =More than 1500 Sold, Less than 2000; Grand Prize =More than 2000 Sold.

2. Do buněk A4:A13 nyní zadejte nějaká čísla.

3. Do buňky B4 zadejte následující vzorec: =KDYŽ($A4>500, $A4, 0).

POZNÁMKA: Všimněte si znaku dolaru před písmenem pro sloupec A. Umístěte kurzor na první adresu obsahující A a následně použijte funkční klávesu F4, která vám umožní přepínat mezi absolutní a relativní adresací. Klávesu F4 opakovaně tiskněte tak dlouho, dokud se před písmenem A neobjeví znak dolaru (a to pro všechna písmena A ve vzorci). Znak dolaru říká Excelu, že při kopírování vzorce nemá měnit písmeno sloupce, ale pouze čísla řádků. Pokud byste umístili znak dolaru jak před písmeno sloupce, tak před číslo řádku, pak se při kopírování vzorce nebude měnit nic.

4. Zkopírujte vzorec z buňky B4 do buněk C4, D4 a E4. Následně vzorec upravte následovně: buňka C4 bude obsahovat vzorec =KDYŽ($A4>1000, $A4, 0); buňka D4 vzorec =KDYŽ($A4>1500, $A4, 0) a buňka E4 vzorec =KDYŽ($A4>2000, $A4, 0). Vzorce pak zkopírujte do příslušného sloupce do buněk pod těmito buňkami C4, D4, resp. E4.

5. Vzorec sice funguje tak, jak má, nicméně ještě musíte každý sloupec zkontrolovat, abyste zjistili, kdo vyhrál cenu, protože každý sloupec zobrazuje VŠECHNY hodnoty větší než číslo ve vzorci. To sice u malé tabulky nevadí, ale u rozsáhlejších tabulek přesahujících velikost monitoru to už je problém.

6. Pro tento účel použijeme vnořený příkaz KDYŽ. Zopakujte operace prováděné ve výše uvedených bodech 1, 2 a 3 pro řádek 20, nicméně namísto vzorce v bodu 3 zadejte do buňky B20 následující vzorec: =KDYŽ(A($A20>500,$A201000,$A201500,$A202000,$A20,0). Poslední vzorec je jiný, protože zde není žádné „menší než“. Vzorce opět rozkopírujte do příslušného sloupce do buněk pod těmito buňkami C4, D4, resp. E4. Následně se podívejte na každý sloupec a okamžitě zjistíte, kdo je v příslušné kategorii vítězem.

Základní a vnořená varianta příkazu KDYŽ

 

Pokračování

 

autor JD Sartain, David Čepička


Mobilní verze našich dalších titulů

 
 
Nahoru
 
Nahoru
 
© IDG Czech Republic, a.s.
 
*